Download Mac OS X i386

The latest release version is 3.0.2

"Unknown developer" error when installing (Mac OS X 10.7 and later)

If you get the message that the FPC installer was created by an unknown developer and cannot be opened, right-click on the installation package and choose "Open" in the contextual menu. This workaround is required because we don't pay Apple 79 euro per year, which would prove you can trust us.

Xcode 5+ compatibility (OS X 10.9 and later; for OS X 10.8, see below)

FPC 3.0.2 is qualified for use with Mac OS X 10.4 till OS X 10.11, and with macOS 10.12. Xcode 5 and later however no longer install the command line tools by default, which are required by FPC. To install them manually, open "/Applications/Utilities/Terminal", execute xcode-select --install and choose "Install". Afterwards, FPC will function correctly.

Xcode 4.3-5.x compatibility (Mac OS X 10.7/OS X 10.8)

FPC 3.0.2 is qualified for use with Mac OS X 10.4 till OS X 10.11, and with macOS 10.12. Xcode 4.3 and later however no longer install the command line tools by default, which are required by FPC. To install them manually, open Xcode, go to Preferences, select "Downloads;" and install the "Command Line Tools". Afterwards, FPC will install and function correctly.

Xcode 3.2.x-4.2 compatibility (Mac OS X 10.6)

FPC 3.0.2 is qualified for use with Mac OS X 10.4 till OS X 10.11, and with macOS 10.12. There is however an issue when compiling dynamic libraries with FPC under Mac OS X 10.6 due to a bug in the Xcode 3.2.x linker. This bug has been fixed in Xcode 4. You can work around the bug in Xcode 3.2.x by using the -k-no_order_inits command line parameter when compiling a dynamic library.

Download the 3.0.2 release in 1 big file:


Back to mirror list
Back to general download page